Statistika v Exceli

Jan Snyrych snyrych na braillnet.cz
Středa Duben 5 17:46:38 CEST 2006


Dobrý den,

buňky v Excelu můžete porovnávat pomocí funkce KDYŽ (bohužel nevím, jak se 
jmenuje ve slovenském, nebo anglickém Excelu).

Pokud např. budete mít v buňkách A1 a B1 dvě čísla a budete chtít, aby v 
buňce C1 bylo napsáno buďto "úbytek", když B1 bude menší než A1, nebo 
"přírůstek" v opačném případě, musíte do C1 zapsat tento vzorec:

=KDYŽ(B1<A1;"úbytek";"přírůstek")

Funkce KDYŽ má tři parametry oddělené středníky. První parametr "B1<A1" je 
podmínka. Pokud je podmínka splněna, je výsledkem funkce druhý parametr 
"úbytek", pokud podmínka splněna není, je výsledkem funkce třetí parametr 
"přírůstek".

Jedinou vadou na kráse uvedeného příkladu je to, že podmínka B1<A1 není 
splněna, i když A1 se rovná B1, takže i tehdy bude výsledkem "přírůstek", 
přestože buňky se rovnají.

Nejlepší je asi, pustit si Excel a vyzkoušet si to.

Přeji hezký večer
Honza Šnyrych

----- Original Message ----- 
From: "Štefan Kiss" <stefan.kiss na nextra.sk>
To: "Pro fanousky vypocetni techniky" <fanda na tereza.fjfi.cvut.cz>
Sent: Tuesday, April 04, 2006 9:18 AM
Subject: Statistika v Exceli


   Ahojte priatelia!

  Obraciam sa najmä na exaktne mysliacich používateľov Excelu. Čaká ma v 
zamestnaní úloha spracovať štatistiku  za minulý rok, kde mám zratúvať rôzne 
číselne vyjadrené počty a porovnávať ich s predošlým rokom. Dávam to do 
Excelu, kde viem v pohode vkladať jednotlivé hodnoty a Excel ich môže 
automaticky napr. pomocou funkcie sum sčitovať. Chcem sa však spýtať, či 
neviete náhodou v exceli o funkcii, ktorá by dokázala porovnávať. Teda napr. 
ak mám v bunke A1 počet 200 za tento rok a v bunke A2 počet 300 za rok 
minulý, dá sa nejako napísať vzorec, podľa ktorého by mi v bunke A3 Excel 
zobrazil rozdiel? Samozrejme viem napísať vzorec, podľa ktorého sa od A1 
odčíta A2 alebo naopak. Tu však je ten problém, že nie v každom stĺpci musí 
byť prvé číslo väčšie, napokon ako v štatistike. Takže by bolo treba, aby 
Excel sám detekoval, či je číslo v A1 väčšie alebo menšie ako A2 a na 
základe toho sám v bunke A3 zobrazil, či máme nárast alebo úbytok. Dá sa to 
nejako?

     Za radu ďakujem

    š Kiss




Další informace o konferenci Fanda